Welcome

Welcome to Sonometrics FAQ page. Please select a topic listed below.

  1. FAQ: Hardware and Technical Information [image] (Crystal information, board information, analog and DAC specifics, principles of sonomicrometry.

  2. FAQ: Acquisition [image] (SonoLAB, Data Convert)

  3. FAQ: Analysis [image] (SonoVIEW, CardioSOFT, SonoXYZ, SonoVOL)


FAQ: Hardware and Technical Information

To further identify the question, please select from the following:

  1. Board information [image] (size, diagrams, installation procedures)

  2. Crystal information [image] (size and specifications, cleaning, number of uses, suggested crystals for applications)

  3. Analog channels [image] (voltage required, conversion to unit of measurement)

  4. Principles of Sonomicrometry.

  5. DAC Information [image] (output range, distance vs voltage, limitations if any)

  6. TRX Box


Board Specifications

Sonometrics hardware currently consists of three computer boards connected by 2 ribbon cables. For installation procedures please go to Board Installation.

  1. Transceiver Controller board.

  2. Transceiver Counter board

  3. A/D Controller board.


Board Installation

  1. Turn computer off and unplug the power cord.

  2. Remove the cover by unscrewing three screws on back plate of computer.

  3. With the cover removed, examine the number of available slots to ensure that at least three consecutive ISA slots exist. For systems that have 16 to 32 Transceiver Channels, you will need four consecutive ISA slots.

  4. If three consecutive slots are not available, you will need to move the existing cards to free up the space. Be careful to reconnect any cables that you remove during this process. It is advisable that once the cards have been repositioned, start the computer to ensure nothing has gone wrong with regular system performance.

  5. With the power off and the computer unplugged, position the Transceiver Counter Board in a vacant slot that is closest to the outer edge of the computer. For systems that are 16 to 32 Channels, there will be an "A" Transceiver Counter Board and a "B" Transceiver Counter Board. Position the "A" Board in the slot closest to the outer edge. The "B" Board sits in the next consecutive slot. When the card(s) is(are) properly placed, the back plate connector should make a tight fit with the back of the computer case.

  6. Repeat procedure 5) for the A/D Controller Board into next adjacent slot.

  7. Repeat procedure 5) for the Transmitter Controller Board in the slot adjacent to the A/D Controller Board. We recommend this order of card placement as it permits a gradual vertical slope for the black, card edge connectors.

  8. Attach card edge connectors for intercard communication. There are two separate cardedge connectors to be placed, the first with 20 contacts, and a second with 50 contacts. Care should be taken when placing the card edge connector. If too much pressure is applied when pressing down on the cards, they may tilt out of their proper seating in the motherboard. (Note: the 20 pin connector connects the Counter Board and the Controller Board, the 50 pin connector connects all three boards).

  9. Power up the computer and verify normal system operation by starting SonoLAB and allowing a full system diagnostic to be performed at boot up. If any board failure messages are given, please reconfirm board order and contact with mother board and ribbon cables.

  10. If your system operates properly, power down the computer and fasten down each of the Sonometrics’ boards using the provided back plate screws.

  11. Finally, replace the computer cover and secure the fastening screws.


Crystal Information

Crystal features may control many aspects of an experiment. For quick tips, please select from the following:

  1. Individual crystal specifications [image] (size, weight, minimum and maximum distances).

  2. Wire Specifications [image] (diameter, weight, options).


Cleaning Crystals

Sonometrics crystals are made for multiple acute experiments. For cleaning crystals we suggest the following guidelines of what to and not to use:

  1. Do not autoclave or heat sterilize the crystals as they will melt. Gas Sterilization is suggested.

  2. Do not clean with harsh or abrasive solutions. Solutions such as highly concentrated bleach will erode the epoxy from the crystal and cause premature failure. Use a mild soap where possible.

  3. If crystals are fibrosed to the tissue, remove as much tissue as possible and allow crystals to soak. If too much tissue has collected around the crystal and wire they probably have been implanted chronically. Chronically implanted crystals are not suggested for reuse.

  4. If Vet Bond Glue has been used to attach the crystal, a mild solvent may be used to soak the crystals. Crystals should not be left to soak for more than 1 hour.


Wire Specifications


Crystal Selections By Application

Please select from the following:

  1. Chronic Implantation.


Crystal Sizing for Application

Various crystal sizes allow a large range of tissue sizes to be measurements. The distance to be measured should determine the size of crystal used. Attachment options may also be chosen to assist in implantation (larger crystals are recommended if possible). For distances measured for each size of crystals please go to Crystal Specifications [image] or please see crystal pricing page for diagrams and advantages of attachment options.


Crystals for Chronic Implantation

Chronic implantation exposes the crystals to bodily fluids and stress more so than acute implantations. For this reason Sonometrics has developed Silastic Tubing to help shield the crystal wire. Silastic tubing is available on TAC, 2mm and now 1mm crystals with stainless steel wire.

If crystals will not be implanted for extended periods of time, i.e. only for 3 to 21 days, stainless steel wire alone may be used for the crystals. Stainless steel wire is both stronger than copper wire and has been shown withstand chronic implantation better.

Crystal wire length may be customized along with the type of connector and possible extension cables used.

For more information please contact our sales team at (519) 652-6464 or by email to Sales@sonometrics.com.


Acute Implantation.

Acute crystals have lasted from 5 to 100 experiments. For acute experiments copper wire is suggested due to the added flexibility of the wire and lower cost.

In these cases the wire length and connector type or extension cable may be customized. For further information, please contact our sales team at (519) 652-6464 or email to sales@sonometrics.com.


Crystal Specifications


Analog Channels

Please select from the following to better define your question:


Analog Conversion from Digital Units to Volts

Until calibration, SonoLAB acquisition software reads incoming signals as a voltage and converts to a digital unit as follows:

  1. Volt=205.8 Digital Units

  2. Digital Unit=0.00488 Volts

These values may be considered irrelevant since SonoLAB will internally use these numbers to properly calibrate using the values entered by user.


Analog Input Voltage

Sonometrics Digital Sonomicrometer acquires analog signals from external devices to be saved with crystal information or independent of crystal distance readings. Analog signals should have an output voltage between –10 volts and +10 volts.

If the analog signal is not between these limits the signal should be amplified. For a full listing of amplifiers available from Sonometrics Corporation, please contact our sales department by (519) 652-6464 or email to sales@sonometrics.com.


Principles of Sonomicrometry.

Sonomicrometry, as applied to biomedical research, is the measurement of distances within soft tissue by using sound energy. Small piezoelectric crystals perform the task of transmitting and receiving short pulses of ultrasonic energy. These crystals are embedded, sutured, or otherwise fixed to the endpoints of the distances to be measured.

As illustrated, for a single distance measurement, one crystal is electrically energized causing an oscillatory shape change, which results in a burst of sound typically several hundred kHz or a few MHz in frequency. This process is not unlike a hammer hitting a bell. Depending on the shape of the crystal, this sound wave can travel in a narrow beam, or it can radiate in many directions. Eventually, this sound wave will impinge on a second crystal, causing it to produce a weak electrical current in response to the sound-pressure energy emitted by the first crystal.

It is the "time of flight" of the sound wave as it travels between the transmitting and receiving crystals that is actually measured in sonomicrometry. Since the speed of sound in soft tissue is well characterized, a simple calculation (Distance = Velocity x Time) yields the distance between the crystals.

If two, or more, crystals are used as receivers, then a simultaneous distance measurement between the transmitting crystal and all receiving crystals can be made. In addition, it is possible to alter the function of some or all of the crystals so that they are capable of both transmitting and receiving. These crystals are called transceivers. The advantage of having a group of crystals acting as transceivers is that all possible distance measurements between crystals can be obtained.

Typically, 2 to 32 crystals are implanted during an experiment. During operation, the computer rapidly switches these crystals between transmit and receive modes, thus allowing the user to obtain measurements between any of the implanted crystals. The delay between successive measurements is usually small enough to be considered insignificant when compared to biological motion.


DAC Channels

Sonometrics Sonomicrometer system allows the user to send crystals signals to another acquisition system. Please select from the commonly asked questions listed below.

  1. Output range.

  2. Voltage to distance equivalents.

  3. Output Values


Output Range

The voltage range put out by the DAC option is between 0 and 5 volts.


Output Values

Q) When I enter a DAC output value, Sonolab responds by printing "Closest output value" which is sometimes very different than what I wanted. What's going on? Which value is actually being output?

A) In the DAC calibration menu, the user is asked for a desired value (in mm) that will appear on the DAC outputs. It should be noted that the sonomicrometer hardware in the computer is not capable of generating a DAC output that exactly matches the user-defined value. There are limitations in the generated values based partly on the hardware and partly on the version of Sonolab being used.

In older versions of Sonolab, the actual DAC output values were (roughly) multiples of 25 mm if the system in question had the standard sonomicrometer resolution (0.024 mm). For hi resolution systems (0.015) there was a better match between the desired and actual output, usually to within 1 mm. With newer versions of Sonolab and standard resolution systems, this situation improved and the DAC output value can more closely match any desired user value, usually to within 2 mm.

NOTE: The DAC output has a basic output limitation of 63 mm (hi-resolution system) or 97 mm (standard resolution), and for systems with older software this cannot be changed. On these systems any distance that exceeds those values would not be output correctly on the DAC channels. With newer versions of Sonolab a scaling factor has been added to extend the maximum output range of the DAC by factors of 2 and 4. However, if your measurements never exceed 63 or 97 mm then this situation would not affect you.

In any case, the user should note the "Closest output value" when calibrating the DAC outputs because that is the actual value being output by the DAC channel in question, regardless of what the desired user value is. The only exception to this rule is when the desired user value exceeds the maximum DAC output, in which case explaining exactly what the DAC output value represents is problematic.


DAC Voltage to Distance Equivalents

when used the DAC sends out a voltage reading equal to a distance measurement. The voltage sent is dependant on the resolution of the sonomicrometer system. Please select from the following.


100MHz (15um) Resolution DAC Voltage

The following is a graphical representation of voltage vs distance output by the DAC.


64MHz (24um) Resolution DAC Voltage

The following is a graphical representation of voltage vs distance output by the DAC.


TRX Box

  1. Setting the Sensitivity


Sensitivity Control

Q: What do the knobs on the front of my TRX box do?

A: These knobs are your sensitivity knobs.

As shown on the figure below, Transmitters are at the top and Receivers are the side.

When Tx 1 pings (transmits), Rx 2 hears some noise due to cross talk - this is the noise that you have Rx2 not remember by using the inhibit delay. Next you want to set your sensitivity to hit the real wave of transmitter 1 that receiver 2 hears. This is a theoretical drawing, a real drawing would have more noise and your sensitivity would have to be decreased in order to get the real wave. Please refer to the manual for sensitivity adjustments.

Sensitivity setting

Decrease sensitivity - line moves up onto a higher rising point on the wave

Increasing sensitivity - line moves down to a lower rising point on the wave